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General Overview

This program is designed to give you the flexibility of managing projects or other activities in a dynamic 
environment where you may need to adjust your plans frequently.    You can quickly create any plan to get
ballpark schedule, cost, and income estimates.    For example, you may use it to:

o Schedule and estimate a construction project.
o Schedule and estimate a landscape project.
o Schedule and estimate a software development project.
o Track the overall schedule and costs of jobs.
o Use it as a planning "white-board" where you just draw out your tasks over a specific time period.
o Schedule resource usage (such as conference rooms, vehicles, etc.).

To create any plan, a planning grid is presented that looks like a spreadsheet.    The columns of the 
planning grid represent time with time increasing as you move to the right.    Each row in the planning grid 
is used to determine the vertical placement of an event.

To create an event on the planning grid, you simply draw it by positioning the mouse cursor at the desired 
location and then clicking and dragging the mouse cursor for the desired time period for the event.    A 
rectangle (event bar) representing the event will be drawn.    To move the event bar, click on it and drag it 
to the desired position.    To change the duration of an event, click and drag the edge of the event bar.

Each event may be assigned several resources.    The time availability of each resource is determined by
a calendar.    All resources may use the same calendar or each resource may use its own unique 
calendar.

For each event you may define a fixed start time or you may specify predecessors to an event that must 
complete before the event starts.

For each event you may specify a duration and have the program automatically calculate how many 
hours will be needed by each resource assigned to the event.    Or you may specify how many resource 
hours are needed for an event and the program will automatically calculate the duration of an event.

Please note that this program is not intended for use when you have to define thousands of events for a 
plan.    It is recommended that no more than a few hundred events be created for any plan.



Calendar Overview

A calendar defines the available time for a resource.    Many resources may use the same calendar or 
each resource may use a unique calendar.

The calendar document is divided into two areas.    On the left is the layout of the currently selected 
month.    On the right side is the schedule for the currently selected day or days of the month.    Current 
days are selected by clicking directly on the desired day in the monthly display.    Whenever a new day is 
selected, the associated schedule for the day is automatically displayed in the schedule display area.

Monthly Display Area (left side)
To change the monthly display to a different month, use the horizontal scroll control that is located to the 
left of the month display title.

To change the year of the month display, use the horizontal scroll control that is located to the right of the 
month display title.

Days that are assigned schedules (other than the default condition) are shaded.

Schedule Display Area (right side)
A schedule defines the available hours for the selected days.    Many schedules may be defined for a 
given calendar.

The available time is represented in the vertical box labeled "Time".    The color next to the time indicates 
the availability of the time slot (usually green means available and red means not available).

To change the time schedule click on the time and the associated color status area will change to the 
opposite state.    To change the state of a continuous time period, click on the beginning time and drag the
mouse cursor to the end time.

Schedules may be of the following types:

Default - The default schedule defines the daily schedule for all days that have no other schedule 
assigned.

Pattern - The pattern schedule defines the same schedule for the specified days of the week.    For 
example, all Saturdays may be defined to have the same schedule.

Every Month - This type of schedule defines the schedule for days of a month.    For example, the 
15th day of every month could be defined to have a certain schedule.

Every Year - This type defines the schedule for a month and day of each year.    For example, this 
can be used to define a schedule for a holiday such as January 1st for New Year's Day.

Do Not Repeat - This type defines a schedule for a specific date that occurs once and will not be 
repeated.    For example it can be used to specify the vacation dates for an employee.

Selecting Days for a Schedule
First adjust the monthly display so the proper month is shown.

To select a single day, click on the desired day of the month.

To select a period of contiguous days, click on the first day of the period and drag the mouse cursor to the
last day of the period.



To select a day of the week, click on the name of the day at the top of each column of days.



Plan Overview

A plan consists of a group of events.    For each event, information such as its start time, end time, 
resources required, cost, and income amounts are stored.

The visual layout of a plan is similar to the rows and columns of a spreadsheet.    For the planning grid 
however, time is always on the horizontal axis and a line number is on the vertical axis.    Each event 
appears as a rectangle that is positioned on the planning grid at the proper time slot.

Events in a plan are created by using the click and drag capability of the mouse.    To view the details of 
an event, double-click on the desired event.

Events can be created in a "free-form" manner so they may be defined anywhere on the surface of the 
planning grid.    As an event is created, the start and end times are automatically assigned based on the 
position it is drawn on the grid.

An event can be related to another by specifying one or more predecessor events.    In this case the event
cannot start until the latest completion of all the defined predecessor events.    When the completion time 
of a predecessor event is changed, the start time of the subsequent event is automatically calculated.

Refer to Creating a Plan and Modifying an Event for more detailed information.



Resource Overview

Each event in a plan requires that at least one resource to be assigned to it.    The resource may be a 
person or any entity that can be associated with a calendar time frame.

Refer to Creating a Resource for more information.



Multiple Document Interface

This application uses the Window's Multiple Document Interface capabilities to manage the display.    
Each plan, resource, or calendar is displayed in a separate document window so it is possible to view 
several plans, resources, and calendars at the same time.

The "Window" menu can be used to arrange the opened documents.



Data Files

This program automatically creates and maintains the necessary data files.    You only have to know the 
names (not filenames) of the resources, calendars, and plans you create.

The location of the data files can be specified by the "Directories" option of the "Options" menu.    This 
option can only be used when all current document windows are closed.    If the directory you choose 
does not have any existing data, a blank set of files will be automatically created.

You may have different sets of plans in different directories, however be aware that a plan can only use 
the resources and calendars that are in the same directory as the plan.    To maintain the integrity of the 
data, all of the files within the directory should be saved or restored completely as a group.

Data files have the following names;
pvcal.dat - contains the calendars.
pvrsc.dat - contains the resources.
pvidx.dat - contains an index of all the plans.
pvYYMMDD.SSS contains the data for a plan where:

YY = last two digits of the current year
MM = two digits for the current month
DD = two digit for the current day of the month
SSS = three digits for the number of the plan created for the date.



Program Support and Distribution

Telephone Support
(808) 395-5587 (Hawaii time).    Voice messages taken during off-hour periods.

CompuServe
Send messages to 71223,3653.

Send Correspondence to:
Sapphire Software Inc.
6650 Hawaii Kai Drive
Suite 219
Honolulu, Hawaii    96825

Distribution
You may request a copy of this program directly from Sapphire Software Inc.    Please specify the type of 
diskette you require.

You may pass along copies of this program (in its original form) for other users to evaluate.

If you are a shareware vendor or a BBS SSYOP, please refer to the "vendor.doc" file for additional 
information.



Program Registration

DISCLAIMER - AGREEMENT
Users of this software must accept this disclaimer of warranty:
"This software is supplied as is.    The author disclaims all warranties, expressed or implied, including, 
without limitation, the warranties of merchantability and of fitness for any purpose.      The author assumes 
no liability for damages, direct or consequential, which may result from the use of this software."

This software is a Shareware program and is provided at no charge to the user for evaluation.    Feel free 
to share it with your friends, but please do not give it away altered or as part of another system.    The 
essence of Shareware software is to provide personal computer users with quality software without high 
prices, and yet to provide incentive for programmers to continue to develop new products.

If you find this program useful and find that you are using it after a reasonable trial period, you must make
a registration payment of $29 to Sapphire Software Inc.    The registration fee will license one copy for 
your use only, on any one computer at any one time.

Upon payment of the registration fee, you will receive the most current version of this program.    If you 
already have the current version, you will automatically receive (at no charge) the next version if it 
becomes available within 90 days of your registration.

Registered users also receive free support on the two most recent releases of this program.

Site-License arrangements may be made by contacting Sapphire Software Inc.

To register, follow the directions below or use the information provided in the "register.txt" file:

1. Fill in the information in the dialog box presented by the "Registration" option of the "Help" menu.

2. Use the "Print" button to print the registration form.

3. Verify the printed information and manually complete the registration form.

4. Select the "Register" button to save the registration information.

5. Mail the registration form and your check (payable to Sapphire Software Inc.) to the address 
shown on the registration form.

Before registration is completed, the startup information dialog box will not close until the "Ok" button    is 
clicked or the carriage return key is hit.    Once registration has been completed, the startup information 
dialog box will automatically close after a few seconds.

The registration information is stored in a Window's private initialization file.    If this file is accidentally 
deleted, the program will start as if you have not registered even if you already    registered and paid your 
registration fee.    You will need to re-enter the registration information and use the "Register" button to 
store the information into the initialization file.    The next time the program starts, the startup information 
dialog box will automatically close.

Refer to the Program Support and Distribution section for additional information.



Creating a Calendar

Select the "New" option from the "File" menu and select the "Calendar" document type to create a new 
calendar.    After defining the schedules for the calendar, select the "Save" option from the "File" menu.    A
dialog box will prompt for the name of the new calendar.    Enter the name of the calendar and select "Ok" 
to create the new calendar.

To define a schedule within the calendar:

1. Select the day or days of interest from the monthly display.

2. Click on the "New" button and a dialog box will appear.

3. Select a type of schedule and enter the name of the new schedule.    The new name will appear in
the schedule area display.

4. Change the available time schedule as necessary.    Remember that changing the available time 
schedule only affects the schedule that is shown in the "Assigned Schedules" box.

Refer to Working with Calendar Schedules for more information.

To create a new calendar that is similar to an existing one, use the "Save As" option of the "File" menu.



Creating a Plan

First define all the calendars needed by the resources.    Next define all the resources needed by the 
plan.    Then proceed to creating the events for the plan.

Select the "New" option from the "File" menu and select the "Plan" document type to create a new plan.    
Enter the desired events into the document then select the "Save" option from the "File" menu.    A dialog 
box will prompt for the name of the new plan.    Enter the name of the plan and select "Ok" to create the 
new plan.

Creating Plan Events - Method 1: 

1. Position the mouse cursor to the desired location on the planning grid.

2. Click and drag the mouse cursor for the desired event duration.

3. The new event will be automatically assigned a temporary name.

4. Double-click on the newly create event to enter detailed event information.    At this time you can 
give the event a name and adjust the time information as needed.    For additional information 
refer to the "Modify an Event" topic.

Creating Plan Events - Method 2: 

1. Select the "New" option from the "Edit" Menu.

2. A dialog box will appear.    This dialog box is the same as the one that appears as in step 4 in the 
first method described above.    However, information such as the event name, duration, and line 
number location are not automatically provided.    These will have to be entered.

To create a new plan that is similar to an existing one, use the "Save As" option of the "File" menu.



Creating a Resource

Select the "New" option from the "File" menu and select the "Resource" document type to create a new 
resource.    Enter the desired data into the document then select the "Save" option from the "File" menu.    
A dialog box will prompt for the name of the new resource.    Enter the name of the resource and select 
"Ok" to create the new resource.

The following resource information fields are available for input:

Description - Enter a description for this resource.

Calendar - Select a calendar to be used by this resource.    This will be the default calendar selection 
whenever this resource is chosen for an event.

Usage % - Enter a percent utilization of available calendar time by this resource.    If you want the 
resource to be used fully, enter 100.    If you want the resource to be used only half of the available 
calendar time, enter 50.

Class - This is just used to classify the resource so that you may identify similar resources.

Income - Enter an amount in dollars that is used to calculate the amount of income generated by this 
resource per specified minutes of time.    This value may be entered with a decimal point for fractions 
of a dollar.

Cost - Enter an amount in dollars that is used to calculate the amount of cost generated by this 
resource per specified minutes of time.    This value may be entered with a decimal point for fractions 
of a dollar.

per - The number of minutes per income or cost amounts.

Notes - Additional notes about the resource.

To create a new resource that is similar to an existing one, use the "Save As" option of the "File" menu.



Modifying an Event

To move an event, click on the event and drag the event to the desired position.

To change the start or end time of an event, position the cursor near the left or right edge of the event bar 
until a horizontal arrow cursor appears.    Click and drag the edge to the desired position.

To modify event information, double-click on the event or select the "Modify" option from the "Edit" Menu.  
A dialog box will appear with the following information.

Name - Each event must have a unique name.    This name appears in the event bar.

Description - Additional information to describe the event.

Start Time - The start time for the event.    If this event has predecessors defined, the start time will 
be automatically calculated.    If no predecessors are defined enter this information in "MM/DD/YY 
HH:II" format where:
 MM = month (1-12)

DD = day of month (1-31)
YY = last two digits of year (92 = 1992, 01 = 2001)
HH = hour of day
II = minutes of hour

End Time - The end time is automatically calculated and displayed.

Duration - This is the elapsed time from the start time to the end time.

Resource Usage - The information in this box refers to resource utilization.

Total Time - This is the total amount of resource time that is allocated from all the resources for 
this event.    Below the total time is a list box which shows how much time is allocated to each 
resource.

Total Cost - This is the total cost of all the resources used for this event.    The cost for each 
resource is determine by multiplying the allocated time by the resource cost as defined in the 
resource document window.

Income - This is the total income generated by all the resources for this event.

Calculate based on - The information in this box determines what method of calculation will be used 
with this event.    One of the following methods may be used:

Duration - Interpret the entered quantities as elapsed time and calculate the "Total Time" used by
all resources.

Time for All Resources - Interpret the entered quantities as "Total Time" used by all resources 
and calculate the duration (elapsed time).

Time per Resource - Interpret the entered quantity as the time used by the first resource in the 
resource list and calculate an elapsed time for the event.    Then use the elapsed time to calculate
the total time used by all resources.

Days (Calculate based on) - Number of days.

Hrs (Calculate based on) - Number of hours.



MIn (Calculate based on) - Number of minutes.

Show Days (Calculate based on) - To display the number of days for a defined quantity click on this 
control to place an X in it.

1 Day = 8 Hours (Calculate based on) - This is used for the condition when a typical work day is 8 
hours long.    To see the quantity displayed in number of working days, enable this option by clicking 
on this control to place an X in it. 

Class - This is used as additional information to identify similar types of events.

Line - The line number on the planning grid that the event will be displayed on.    You can change this 
to move an event vertically.

Fixed Income - A fixed income in dollars that is associated with this event.    A decimal point may be 
used for fractions of dollar.

Fixed Cost - A fixed cost in dollars that is associated with this event.    A decimal point may be used 
for fractions of dollar.

Predecessors - List of defined predecessor events for this event.    The event cannot start until all the
predecessor events have been completed.

Resources - List of resources used for this event.

Notes - Additional notes about this event.

Predecessors (Button) - This button invokes a dialog box to define the predecessor events.    To 
place an event into the "Selected Predecessors" list, click on the event name in the "Existing Events" 
list then click on the "Insert" button.

Once an event has been placed on the "Selected Predecessors" list it may be deleted or moved.    To 
delete the event from this list, click on the event name then click on the "Delete" button.    To move the
event, click on the event name then click on the "Move Up" or "Move Down" button.

Resources (Button) - This button invokes a dialog box to define the resources for the event.    To 
select a resource, click on the resource name in the "Resources" list.    A default "Usage %" and 
calendar assignment will be made.    The "Usage %" can be changed by entering a new percentage 
and the assigned calendar can be changed by clicking on a different calendar name in the "Calendar"
list.

Use the "Replace", "Insert" (insert before), or "Add" (add to end of selected list) buttons to place the 
resource into the "Selected Resources" list.

Once a resource has been placed into the selected list, it may be deleted with the "Delete" button or 
moved with the "Move Up" or "Move Down" buttons.

Calculate (Button) - After an input quantity has changed, this can be used to force a re-calculation 
and to display the results in the dialog box.

Print (Button) - Use this to print the current dialog box contents.



Working with Calendar Schedules

Multiple Schedules
It is possible to have more than one schedule assigned to a given date.    However, only one schedule is 
applied at any given time.    When determining what schedule to apply to a date, the following type order 
is used:

1. "Do Not Repeat"
2. "Every Year"
3. "Every Month"
4. "Pattern"
5. "Default"

When more than one schedule of a type is defined, the one defined last is applied first.

The "Assigned Schedules" list box lists the schedules assigned to the currently selected date.    To view 
the time schedule, select the schedule name from the list box.

Changing Time
The schedule is determined by the state of the information shown in the vertical box labeled as "Time".    
This time schedule applies to the item that currently appears in the "Assigned Schedules" box.

To change the time schedule for the current item, click on the time bars to turn the state of the time 
periods from available (green) to not-available (red).    The changes are immediately accepted with no 
confirmation dialog box.    However, to revert back to the original time schedule click on the "Revert" 
button.

Buttons
New - Immediately after selecting a date, click on this button to create a new schedule.

Delete - Use this to delete the currently displayed schedule.

Rename - Use this to rename the currently displayed schedule.

Revert - This button is enabled whenever it is possible to revert back to an original time schedule and 
discard any changes.



File Menu

The options in this menu do not deal with files in the traditional sense.    This program simply uses names 
for calendars, resources and plans and the actual file names for the data are hidden from the user.

New - Create a new plan, calendar, or resource.

Open - Open an existing plan, calendar, or resource.

Save - Save the plan, calendar, or resource in the active document window.

Save As - Save the plan, calendar, or resource in the active document window with a new name and use 
the original document as the basis for a new one.    This is equivalent to copying a document.

Delete - Delete the selected plan, calendar, or resource.

Print - Print the information in the plan, calendar, or resource in the active document window.

Exit - Exit this application.



Edit Menu

This menu only applies to a plan document.

New - Create a new event.    Use this option when you do not want to use the click and drag method. 

Duplicate - Copy an event so a similar on can be easily created.    A dialog box listing all the events will 
appear.    Select the event from this list.    If an event was highlighted before this option was selected, it will
appear as the selected event in the dialog box list. 

Delete - Delete an event.    A dialog box listing all the events will appear.    Select the event from this list.    
If an event was highlighted before this option was selected, it will appear as the selected event in the 
dialog box list. 

Modify - Modify an event.    A dialog box listing all the events will appear.    Select the event from this list.   
If an event was highlighted before this option was selected, it will appear as the selected event in the 
dialog box list. 

Insert Line - Insert a blank line before the currently selected line position.    To select a line, click on the 
line number.

Clear Line - Clear all the events on the currently selected line.

Delete Line - Delete all the events on the currently select line, and shift all events up one line.



Info Menu

Calendar - Provide additional information about the currently selected calendar.

Plan - Provide additional information about the currently selected plan.



Reports Menu

Resource List - Show the list of all resources with an option to print the list.

Calendar List - Show the list of all calendars with an option to print the list.

Plan List -    Show the list of all plans with an option to print the list.



Options Menu

Scale - This option is only enabled when a plan or a calendar is the active document.    With a plan 
document, this option specifies the time resolution of each column in the planning grid.    With a calendar 
document, this option specifies the resolution of the available time display.

For a plan document, a dialog box appears with the following fields:

Column Time Scale - Each column may represent a day, week, month, or year.

Mouse Cursor Resolution Units - The mouse position will be rounded to the specified units of 
days, hours, or minutes.

Event Duration Resolution - When the event is created with the mouse, the duration will be 
rounded to some multiple of the amount specified here.    For example if the value in this field is 
one and the "Mouse Cursor Resolution Units" is "days", then the event duration will be rounded to
the nearest day.

Column Width - The width of each displayed column in logical inches.

Line Height - The height of each displayed line in logical inches.

For a calendar document, a dialog box appears with the following fields:

Time Resolution of Day's Schedule - This specifies the number of minutes for each time 
segment in the time display.

Default Start Time - This specifies the start time that appears at the top of the time display.

Directories - Used to specify the location of the data files and the location of the help file.

Shift Events - Used to shift all the events in the current plan by a specified amount.    The amount to shift 
may be specified in minutes, hours, or days.



Window Menu

Tile - Follows the multiple document window interface for tiling the windows.

Cascade - Follows the multiple document window interface for cascading the windows.

Arrange Icons - Follows the multiple document window interface standards for arranging the icons for the
open documents.

Close All - Close all the opened plans, resources, and calendars.



Help Menu

Help - Provide help on this application.

About - Provide version information about this application.

Registration - Provides registration information for this product.




